Incorrect Authorization Affecting openclaw package, versions <2026.7.1


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.24% (14th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-OPENCLAW-21709015
  • published25 Oct 2026
  • disclosed26 Sept 2026
  • creditYuval Dinodia

Introduced: 26 Sep 2026

CVE-2026-100595  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade openclaw to version 2026.7.1 or higher.

Overview

openclaw is a 🦞 OpenClaw — Personal AI Assistant

Affected versions of this package are vulnerable to Incorrect Authorization via the diagnostics export command (/diagnostics), which fails to enforce owner-only authorization. An authenticated non-owner channel sender can request and receive a host diagnostics bundle containing details about the host configuration, runtime, and connected services that are intended exclusively for owners.

References

CVSS Base Scores

version 4.0
version 3.1