Command Injection Affecting openclaw package, versions >=2026.5.2-beta.1 <2026.7.1


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.31% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Command Injection vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-OPENCLAW-21709019
  • published25 Oct 2026
  • disclosed26 Sept 2026
  • creditUnknown

Introduced: 26 Sep 2026

CVE-2026-100599  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade openclaw to version 2026.7.1 or higher.

Overview

openclaw is a 🦞 OpenClaw — Personal AI Assistant

Affected versions of this package are vulnerable to Command Injection via the googlemeet.chrome command, which accepts caller-supplied audio command arrays and executes them on a paired node without passing through the normal system.run approval flow. A tool-enabled agent able to invoke the allowed Google Meet node command can execute attacker-selected processes on the paired node, affecting files, credentials, browser profiles, and availability on that node.

Note: This is only exploitable in deployments with the Google Meet plugin enabled, a paired Chrome node, and the googlemeet.chrome node command allowed.

References

CVSS Base Scores

version 4.0
version 3.1