Improper Input Validation Affecting @openzeppelin/contracts package, versions >=4.1.0 <4.3.2


0.0
high
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-OPENZEPPELINCONTRACTS-1585627

  • published

    16 Sep 2021

  • disclosed

    15 Sep 2021

  • credit

    Unknown

How to fix?

Upgrade @openzeppelin/contracts to version 4.3.2 or higher.

Overview

@openzeppelin/contracts is a library for contract development.

Affected versions of this package are vulnerable to Improper Input Validation. Upgradeable contracts using UUPSUpgradeable may be vulnerable to an attack affecting uninitialized implementation contracts.

Due to this vulnerability, it is recommended that all projects using the UUPS proxy pattern should initialize their implementation contracts, even after upgrading to the fixed version. An example of how to do this is here.

References