Improper Initialization Affecting @openzeppelin/contracts package, versions >=4.1.0 <4.3.2


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-OPENZEPPELINCONTRACTS-1920946

  • published

    15 Nov 2021

  • disclosed

    15 Nov 2021

  • credit

    Unknown

How to fix?

Upgrade @openzeppelin/contracts to version 4.3.2 or higher.

Overview

@openzeppelin/contracts is a library for contract development.

Affected versions of this package are vulnerable to Improper Initialization via uninitialized implementation contracts using UUPSUpgradeable.