Function Call With Incorrect Argument Affecting @openzeppelin/contracts package, versions >=4.3.0 <4.4.2


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-OPENZEPPELINCONTRACTS-2336323

  • published

    12 Jan 2022

  • disclosed

    12 Jan 2022

  • credit

    @GeraldHolst

How to fix?

Upgrade @openzeppelin/contracts to version 4.4.2 or higher.

Overview

@openzeppelin/contracts is a library for contract development.

Affected versions of this package are vulnerable to Function Call With Incorrect Argument. The GovernorCompatibilityBravo module may lead to the creation of governance proposals that execute function calls with incorrect arguments due to bad ABI encoding.