Information Exposure Affecting @openzeppelin/contracts package, versions >=4.1.0 <4.7.1


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-OPENZEPPELINCONTRACTS-2958050

  • published

    22 Jul 2022

  • disclosed

    21 Jul 2022

  • credit

    Unknown

How to fix?

Upgrade @openzeppelin/contracts to version 4.7.1 or higher.

Overview

@openzeppelin/contracts is a library for contract development.

Affected versions of this package are vulnerable to Information Exposure. SignatureChecker.isValidSignatureNow is not expected to revert. However, an incorrect assumption about Solidity 0.8's abi.decode allows some cases to revert, given a target contract that doesn't implement EIP-1271 as expected.

The contracts that may be affected are those that use SignatureChecker to check the validity of a signature and handle invalid signatures in a way other than reverting. We believe this to be unlikely.

References