Incorrect Calculation Affecting @openzeppelin/contracts package, versions >=4.3.0 <4.7.2


0.0
high

Snyk CVSS

    Attack Complexity Low
    Integrity High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-OPENZEPPELINCONTRACTS-2964946
  • published 2 Aug 2022
  • disclosed 2 Aug 2022
  • credit Unknown

How to fix?

Upgrade @openzeppelin/contracts to version 4.7.2 or higher.

Overview

@openzeppelin/contracts is a library for contract development.

Affected versions of this package are vulnerable to Incorrect Calculation via the GovernorVotesQuorumFraction module. This vulnerability is exploitable by passing a proposal to lower the quorum requirements, leading to past proposals possibly becoming executable if they had been defeated only due to lack of quorum, and the number of votes it received meets the new quorum requirement.

Mitigation:

Users unable to upgrade should consider avoiding lowering quorum requirements if a past proposal was defeated for lack of quorum.