Improper Verification of Cryptographic Signature Affecting @openzeppelin/contracts package, versions <4.7.3


0.0
high

Snyk CVSS

    Attack Complexity High
    User Interaction Required
    Scope Changed
    Confidentiality High
    Integrity High

    Threat Intelligence

    EPSS 0.06% (23rd percentile)
Expand this section
NVD
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-OPENZEPPELINCONTRACTS-2980279
  • published 14 Aug 2022
  • disclosed 14 Aug 2022
  • credit Unknown

How to fix?

Upgrade @openzeppelin/contracts to version 4.7.3 or higher.

Overview

@openzeppelin/contracts is a library for contract development.

Affected versions of this package are vulnerable to Improper Verification of Cryptographic Signature via ECDSA.recover and ECDSA.tryRecover due to accepting EIP-2098 compact signatures in addition to the traditional 65 byte signature format.