Information Exposure Affecting parcel-bundler package, versions <1.10.0


0.0
low

Snyk CVSS

    Attack Complexity High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-PARCELBUNDLER-461001
  • published 26 Sep 2018
  • disclosed 21 Sep 2018
  • credit chromium1337

How to fix?

Upgrade parcel-bundler to version 1.10.0 or higher.

Overview

parcel-bundler is a web application bundler.

Affected versions of this package are vulnerable to Information Exposure. A malicious user was able to steal user's code as the origin of requests wasn't checked by websocket server, as long as they share the same network.