Authorization Bypass Through User-Controlled Key Affecting parse-path package, versions <5.0.0


0.0
high

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.09% (37th percentile)
Expand this section
NVD
7.3 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-PARSEPATH-2936439
  • published 28 Jun 2022
  • disclosed 28 Jun 2022
  • credit Rohan Sharma

How to fix?

Upgrade parse-path to version 5.0.0 or higher.

Overview

parse-path is a Parse paths (local paths, urls: ssh/git/etc)

Affected versions of this package are vulnerable to Authorization Bypass Through User-Controlled Key which is unable to detect the right resource.

References