Improper Isolation or Compartmentalization Affecting parse-server package, versions >=9.0.0 <9.10.5-alpha.4<8.6.103


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.29% (22nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-JS-PARSESERVER-21708543
  • published25 Oct 2026
  • disclosed25 Oct 2026
  • creditUnknown

Introduced: 25 Oct 2026

NewCVE-2026-116161  (opens in a new tab)
CWE-653  (opens in a new tab)

How to fix?

Upgrade parse-server to version 9.10.5-alpha.4, 8.6.103 or higher.

Overview

parse-server is a version of the Parse backend that can be deployed to any infrastructure that can run Node.js.

Affected versions of this package are vulnerable to Improper Isolation or Compartmentalization via LiveQuery subscriptions that use a $or query, due to a flawed query hashing function in src/LiveQuery/QueryTools.js. The former queryHash implementation flattened $or clauses into a flat list of conditions and discarded surrounding keys (such as the server-injected _Session user pointer and beforeSubscribe constraints) before hashing, causing distinct queries from different users to produce the same hash. As a result, an authenticated attacker can receive LiveQuery events intended for another user, including that user's session tokens.

CVSS Base Scores

version 4.0
version 3.1