Missing Authorization Affecting parse-server package, versions >=9.0.0 <9.10.4-alpha.4<8.6.101


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.32% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Missing Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-PARSESERVER-21708545
  • published25 Oct 2026
  • disclosed25 Oct 2026
  • creditAdrian Curtin

Introduced: 25 Oct 2026

NewCVE-2026-116165  (opens in a new tab)
CWE-862  (opens in a new tab)

How to fix?

Upgrade parse-server to version 9.10.4-alpha.4, 8.6.101 or higher.

Overview

parse-server is a version of the Parse backend that can be deployed to any infrastructure that can run Node.js.

Affected versions of this package are vulnerable to Missing Authorization via the enforceRoleSecurity function in src/SharedRest.js, which fails to validate that a requested class name is a valid Parse class before processing operations. An unauthenticated attacker can send requests targeting internal collections such as _SCHEMA, allowing deletion of class schemas and removal of class-level permissions on MongoDB without any credentials.

CVSS Base Scores

version 4.0
version 3.1