Improper Authentication Affecting parse-server package, versions >=9.0.0 <9.10.5-alpha.2<8.6.102


Severity

Recommended
0.0
critical
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.28% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Improper Authentication vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-PARSESERVER-21708582
  • published25 Oct 2026
  • disclosed25 Oct 2026
  • creditUnknown

Introduced: 25 Oct 2026

NewCVE-2026-116163  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade parse-server to version 9.10.5-alpha.2, 8.6.102 or higher.

Overview

parse-server is a version of the Parse backend that can be deployed to any infrastructure that can run Node.js.

Affected versions of this package are vulnerable to Improper Authentication via the loadAuthAdapter function in src/Adapters/Auth/index.js, where custom auth adapters that extend the AuthAdapter base class fail to properly validate authData. Because the adapter loading logic does not detect when a custom class instance leaves validation methods as unoverridden defaults, those default no-op implementations are accepted as valid, allowing an attacker to authenticate with arbitrary authData without proper credential verification.

References

CVSS Base Scores

version 4.0
version 3.1