Improper Privilege Management Affecting parse-server package, versions >=9.0.0 <9.10.5-alpha.5<8.6.104


Severity

Recommended
0.0
low
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.38% (33rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Improper Privilege Management vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-PARSESERVER-21708590
  • published25 Oct 2026
  • disclosed25 Oct 2026
  • creditUnknown

Introduced: 25 Oct 2026

NewCVE-2026-116162  (opens in a new tab)
CWE-269  (opens in a new tab)

How to fix?

Upgrade parse-server to version 9.10.5-alpha.5, 8.6.104 or higher.

Overview

parse-server is a version of the Parse backend that can be deployed to any infrastructure that can run Node.js.

Affected versions of this package are vulnerable to Improper Privilege Management via the SMS MFA login code request handler in mfa.js, where req.object.save(null, { useMasterKey: true }) is called instead of saving only the authData field through the original object. Because the full login-request object is saved with master key privileges, an authenticated attacker with administrator access can cause arbitrary login-body fields to be persisted to the user record with elevated privileges, resulting in unauthorized data modification.

References

CVSS Base Scores

version 4.0
version 3.1