Uncaught Exception Affecting parse-server package, versions >=9.0.0 <9.10.6-alpha.2<8.6.110


Severity

Recommended
0.0
high
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.33% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Uncaught Exception vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-PARSESERVER-22220113
  • published5 Nov 2026
  • disclosed3 Nov 2026
  • creditUnknown

Introduced: 3 Nov 2026

NewCVE-2026-121414  (opens in a new tab)
CWE-248  (opens in a new tab)

How to fix?

Upgrade parse-server to version 9.10.6-alpha.2, 8.6.110 or higher.

Overview

parse-server is a version of the Parse backend that can be deployed to any infrastructure that can run Node.js.

Affected versions of this package are vulnerable to Uncaught Exception via an object update that uses a dot notation key targeting the object identifier of a pointer field on a class with an afterSave trigger. When buildParseObjects applies such a key, the pointer loses its identifier and can no longer be serialized by toJSON; the resulting unhandled serialization error propagates out of the trigger pipeline and terminates the Node.js process, causing a denial of service for all clients until the server is restarted.

Note: This is only exploitable against classes that have an afterSave trigger defined; classes without one are not affected.

CVSS Base Scores

version 4.0
version 3.1