Incorrect Authorization Affecting parse-server package, versions >=9.0.0 <9.10.6-alpha.4<8.6.112


Severity

Recommended
0.0
low
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.31% (25th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Incorrect Authorization vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-PARSESERVER-22220114
  • published5 Nov 2026
  • disclosed3 Nov 2026
  • creditUnknown

Introduced: 3 Nov 2026

NewCVE-2026-121413  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade parse-server to version 9.10.6-alpha.4, 8.6.112 or higher.

Overview

parse-server is a version of the Parse backend that can be deployed to any infrastructure that can run Node.js.

Affected versions of this package are vulnerable to Incorrect Authorization via the /upgradeToRevocableSession endpoint, which creates a new session for any valid session token without enforcing the _Session class create class-level permission. An attacker in possession of a user's session token can submit an already-revocable token to this endpoint to obtain additional sessions with a fresh expiration date, bound to an installation ID of the attacker's choosing, that persist even after the original session is logged out.

Note: This is only exploitable if the create class-level permission of the _Session class has been restricted from its default.

CVSS Base Scores

version 4.0
version 3.1