Information Exposure Affecting parse-server package, versions >=9.0.0 <9.10.6-alpha.6<8.6.114


Severity

Recommended
0.0
low
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.21% (11th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications

Snyk Learn

Learn about Information Exposure vulnerabilities in an interactive lesson.

Start learning
  • Snyk IDSNYK-JS-PARSESERVER-22220117
  • published5 Nov 2026
  • disclosed5 Nov 2026
  • creditUnknown

Introduced: 5 Nov 2026

NewCVE-2026-122301  (opens in a new tab)
CWE-209  (opens in a new tab)

How to fix?

Upgrade parse-server to version 9.10.6-alpha.6, 8.6.114 or higher.

Overview

parse-server is a version of the Parse backend that can be deployed to any infrastructure that can run Node.js.

Affected versions of this package are vulnerable to Information Exposure via the object create response in RestWrite.js, which returns field values to callers that lack read access to the created object through class-level permissions or the object's ACL. An attacker with create permission can create objects to obtain values set by Cloud Code triggers, schema default values, and the class default ACL that they are not authorized to read. This affects both direct object creation and sign-up flows where no session is issued.

References

CVSS Base Scores

version 4.0
version 3.1