Authentication Bypass Affecting parse-server Open this link in a new tab package, versions <4.10.11 >=5.0.0 <5.2.2


0.0
critical
  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-PARSESERVER-2932021

  • published

    19 Jun 2022

  • disclosed

    17 Jun 2022

  • credit

    yoshmidev

How to fix?

Upgrade parse-server to version 4.10.11, 5.2.2 or higher.

Overview

parse-server is a version of the Parse backend that can be deployed to any infrastructure that can run Node.js.

Affected versions of this package are vulnerable to Authentication Bypass due to missing validation of certificates from Apple Game Center. Thus, authentication could potentially be bypassed by making a fake certificate accessible via certain Apple domains and providing the URL to that certificate in an authData object.