Information Exposure Affecting parse-url package, versions <6.0.1


0.0
medium

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity High
Expand this section
NVD
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-PARSEURL-2935947
  • published 27 Jun 2022
  • disclosed 27 Jun 2022
  • credit amammad

How to fix?

Upgrade parse-url to version 6.0.1 or higher.

Overview

parse-url is an An advanced url parser supporting git urls too.

Affected versions of this package are vulnerable to Information Exposure due to improper validation.