Improper Verification of Cryptographic Signature Affecting passport-saml package, versions <3.2.2


0.0
high
0
10

Snyk CVSS

    Attack Complexity High
    Confidentiality High
    Integrity High

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.79% (82nd percentile)
Expand this section
NVD
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-PASSPORTSAML-3043103
  • published 13 Oct 2022
  • disclosed 12 Oct 2022
  • credit Felix Wilhelm

How to fix?

Upgrade passport-saml to version 3.2.2 or higher.

Overview

passport-saml is an authentication provider for Passport, the Node.js authentication library.

Affected versions of this package are vulnerable to Improper Verification of Cryptographic Signature by allowing a remote attacker to bypass SAML authentication on a website using passport-saml.

Note A successful attack requires that the attacker is in possession of an arbitrary IDP-signed XML element. Depending on the IDP used, fully unauthenticated attacks (e.g, without access to a valid user) might also be feasible if the generation of a signed message can be triggered.

Workaround

Users who are unable to upgrade to the fixed version should disable SAML authentication.