Authentication Bypass Affecting passport-saml package, versions <1.0.0


0.0
medium
0
10

Snyk CVSS

    Attack Complexity Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-PASSPORTSAML-72411
  • published 2 Oct 2018
  • disclosed 8 Mar 2018
  • credit cintolas

Introduced: 8 Mar 2018

CVE NOT AVAILABLE CWE-287 Open this link in a new tab

How to fix?

Upgrade passport-saml to version 1.0.0 or higher.

Overview

passport-saml is an authentication provider for Passport, the Node.js authentication library.

Affected versions of this package are vulnerable to Authentication Bypass via the SAMLRequest parameter.