Arbitrary Code Execution Affecting pixl-class package, versions <1.0.3



    Attack Complexity Low
    Confidentiality High

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.35% (68th percentile)
Expand this section
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-PIXLCLASS-564968
  • published 9 Apr 2020
  • disclosed 10 Mar 2020
  • credit JHU System Security Lab

How to fix?

Upgrade pixl-class to version 1.0.3 or higher.


pixl-class is a library that allows you to create classes in a more classical sort of way, including support for static class members, proper constructors, inheritance, and mixins.

Affected versions of this package are vulnerable to Arbitrary Code Execution. The injection point is located in line 26 in the index file class.js; the members argument of the create function can be controlled by users without any sanitization.


var a = require("pixl-class");
var members = {
  __parent:'function(){}; console.log(123)//}'