Improper Input Validation Affecting pnpm package, versions <6.15.1



    Attack Complexity Low
    User Interaction Required

    Threat Intelligence

    EPSS 0.1% (43rd percentile)
Expand this section
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-PNPM-2431149
  • published 22 Mar 2022
  • disclosed 22 Mar 2022
  • credit Unknown

How to fix?

Upgrade pnpm to version 6.15.1 or higher.


pnpm is a Fast, disk space efficient package manager

Affected versions of this package are vulnerable to Improper Input Validation via an untrusted search path which causes the application to behave in unexpected ways when users execute PNPM commands in a directory containing malicious content.