Insufficient Validation Affecting redbird package, versions <0.9.1


0.0
medium
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-REDBIRD-174455

  • published

    18 Apr 2019

  • disclosed

    17 Apr 2019

  • credit

    James Thomas

How to fix?

Upgrade redbird to version 0.9.1 or higher.

Overview

redbird is a complete library to build dynamic reverse proxies with the speed and robustness of http-proxy.

Affected versions of this package are vulnerable to Insufficient Validation. There is no option in lib/proxy.js which would allow for disabling TLS1.0 connections, which are considered to be vulnerable and deprecated.