Command Injection Affecting rsshub package, versions <1.0.0-master.4db1c91


0.0
high

Snyk CVSS

    Attack Complexity Low
    Scope Changed
    Confidentiality High

    Threat Intelligence

    EPSS 0.43% (74th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-RSSHUB-1065277
  • published 27 Jan 2021
  • disclosed 27 Jan 2021
  • credit Unknown

How to fix?

Upgrade rsshub to version 1.0.0-master.4db1c91 or higher.

Overview

rsshub is a Make RSS Great Again!

Affected versions of this package are vulnerable to Command Injection. Some routes use eval or Function constructor, which may be injected by the target site with unsafe code, causing server-side security issues.

References