Arbitrary Code Execution Affecting safer-eval Open this link in a new tab package, versions <1.3.4


0.0
critical
  • Attack Complexity

    Low

  • Scope

    Changed

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-SAFEREVAL-173772

  • published

    11 Mar 2019

  • disclosed

    8 Mar 2019

  • credit

    Beny Zeltser

How to fix?

Upgrade safer-eval to version 1.3.4 or higher.

Overview

safer-eval is a safer approach for eval in node and browser.

Affected versions of this package are vulnerable to Arbitrary Code Execution. A payload using constructor properties can escape the sandbox and execute arbitrary code.