Information Exposure Affecting simple-get Open this link in a new tab package, versions <2.8.2 >=3.0.0 <3.1.1 >=4.0.0 <4.0.1


0.0
high
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-SIMPLEGET-2361683

  • published

    26 Jan 2022

  • disclosed

    26 Jan 2022

  • credit

    Unknown

How to fix?

Upgrade simple-get to version 2.8.2, 3.1.1, 4.0.1 or higher.

Overview

Affected versions of this package are vulnerable to Information Exposure. When getting Location response header after fetching a remote url with Cookie, it will follow that url and fetch it with the provided cookie which will be then leaked to the attacker .