Command Injection Affecting spritesheet-js package, versions *


0.0
critical

Snyk CVSS

    Exploit Maturity Proof of concept
    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-SPRITESHEETJS-1048333
  • published 9 Feb 2021
  • disclosed 4 Dec 2020
  • credit JHU System Security Lab

How to fix?

There is no fixed version for spritesheet-js.

Overview

spritesheet-js is a command-line spritesheet (a.k.a. Texture Atlas) generator written in node.js.

Affected versions of this package are vulnerable to Command Injection. It depends on a vulnerable package platform-command. The injection point is located in line 32 in lib/generator.js, which is triggered by main entry of the package.

PoC

var a =require("spritesheet-js");
a('./', { scale:"& touch JHU #",trim:true});

References