Improper Input Validation Affecting strapi package, versions <3.6.10



    Attack Complexity Low
    Privileges Required High
    Scope Changed
    Confidentiality High

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.06% (24th percentile)
Expand this section
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-STRAPI-3034915
  • published 28 Sep 2022
  • disclosed 28 Sep 2022
  • credit Achmad Zaenuri Dahlan Putra

How to fix?

Upgrade strapi to version 3.6.10 or higher.


strapi is a HTTP layer sits on top of Koa.

Affected versions of this package are vulnerable to Improper Input Validation due to mishandling hidden attributes within admin API responses. Exploiting this vulnerability allows users with permission to read user data in the settings section to read all users' data, including password hashes, by manipulating columns when using the filter function.