Improper Access Control Affecting strapi package, versions <3.0.0-beta.17.5



    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    Exploit Maturity Mature
    EPSS 80.07% (98th percentile)
Expand this section
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-STRAPI-480418
  • published 10 Nov 2019
  • disclosed 4 Nov 2019
  • credit brianadeloye

How to fix?

Upgrade strapi to version 3.0.0-beta.17.5 or higher.


strapi is a HTTP layer sits on top of Koa.

Affected versions of this package are vulnerable to Improper Access Control. It mishandles password resets within packages/strapi-admin/controllers/Auth.js and packages/strapi-plugin-users-permissions/controllers/Auth.js.