Cross-site Scripting (XSS) Affecting @theia/preview package, versions <1.3.0


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High

    Threat Intelligence

    EPSS 0.26% (65th percentile)
Expand this section
NVD
9.6 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-THEIAPREVIEW-1079037
  • published 25 Feb 2021
  • disclosed 25 Feb 2021
  • credit Casey Flynn

How to fix?

Upgrade @theia/preview to version 1.3.0 or higher.

Overview

@theia/preview is a Theia - Preview Extension

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). The Markdown Preview (@theia/preview), can be exploited to execute arbitrary JavaScript code.