Improper Input Validation Affecting url-parse Open this link in a new tab package, versions <1.5.0


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-URLPARSE-1078283

  • published

    22 Feb 2021

  • disclosed

    22 Feb 2021

  • credit

    Unknown

How to fix?

Upgrade url-parse to version 1.5.0 or higher.

Overview

url-parse is a Small footprint URL parser that works seamlessly across Node.js and browser environments.

Affected versions of this package are vulnerable to Improper Input Validation. It mishandles certain uses of backslash such as http:\/ and interprets the URI as a relative path.