HTML Injection Affecting valine package, versions <1.3.4


0.0
medium

Snyk CVSS

    Attack Complexity High
    Confidentiality High
Expand this section
NVD
6.1 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-JS-VALINE-72627
  • published 22 Nov 2018
  • disclosed 15 Nov 2018
  • credit Unknown

How to fix?

Upgrade to version 1.3.4 or higher.

Overview

valine is a fast, simple & powerful comment system.

Affected versions of this package are vulnerable to HTML Injection. While uploading a PDF file, An attacker could inject a java script code.