Command Injection Affecting xopen Open this link in a new tab package, versions *


0.0
critical
  • Exploit Maturity

    Proof of concept

  • Attack Complexity

    Low

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-JS-XOPEN-1050981

  • published

    26 Jan 2021

  • disclosed

    26 Jan 2021

  • credit

    JHU System Security Lab

How to fix?

There is no fixed version for xopen.

Overview

xopen is a package that provides a dead-simple Promise API for opening files from Node on Windows, macOS, and Linux.

Affected versions of this package are vulnerable to Command Injection. The injection point is located in line 14 in index.js in the exported function xopen(filepath)

##PoC:

``` var root = require("xopen"); var attack_code = "& touch JHU"; root(attack_code);