Insufficiently Protected Credentials Affecting grafana-11.5 package, versions *


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.33% (71st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-GRAFANA115-17178188
  • published5 Jun 2026
  • disclosed13 Oct 2022

Introduced: 13 Oct 2022

CVE-2022-31130  (opens in a new tab)
CWE-522  (opens in a new tab)

How to fix?

There is no fixed version for Minimos:latest grafana-11.5.

NVD Description

Note: Versions mentioned in the description apply only to the upstream grafana-11.5 package and not the grafana-11.5 package as distributed by Minimos. See How to fix? for Minimos:latest relevant fixed versions and status.

Grafana is an open source observability and data visualization platform. Versions of Grafana for endpoints prior to 9.1.8 and 8.5.14 could leak authentication tokens to some destination plugins under some conditions. The vulnerability impacts data source and plugin proxy endpoints with authentication tokens. The destination plugin could receive a user's Grafana authentication token. Versions 9.1.8 and 8.5.14 contain a patch for this issue. As a workaround, do not use API keys, JWT authentication, or any HTTP Header based authentication.

CVSS Base Scores

version 3.1