Cross-site Scripting (XSS) Affecting grafana-12.0 package, versions *


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
70.06% (100th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-GRAFANA120-17210604
  • published6 Jun 2026
  • disclosed15 Jul 2022

Introduced: 15 Jul 2022

CVE-2022-31097  (opens in a new tab)
CWE-79  (opens in a new tab)

How to fix?

There is no fixed version for Minimos:latest grafana-12.0.

NVD Description

Note: Versions mentioned in the description apply only to the upstream grafana-12.0 package and not the grafana-12.0 package as distributed by Minimos. See How to fix? for Minimos:latest relevant fixed versions and status.

Grafana is an open-source platform for monitoring and observability. Versions on the 8.x and 9.x branch prior to 9.0.3, 8.5.9, 8.4.10, and 8.3.10 are vulnerable to stored cross-site scripting via the Unified Alerting feature of Grafana. An attacker can exploit this vulnerability to escalate privilege from editor to admin by tricking an authenticated admin to click on a link. Versions 9.0.3, 8.5.9, 8.4.10, and 8.3.10 contain a patch. As a workaround, it is possible to disable alerting or use legacy alerting.

CVSS Base Scores

version 3.1