Interpretation Conflict Affecting mediawiki-1.46 package, versions <1.46.2-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.32% (24th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-MINIMOSLATEST-MEDIAWIKI146-20510007
  • published5 Oct 2026
  • disclosed8 Jul 2026

Introduced: 8 Jul 2026

CVE-2026-59882  (opens in a new tab)
CWE-436  (opens in a new tab)

How to fix?

Upgrade Minimos:latest mediawiki-1.46 to version 1.46.2-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mediawiki-1.46 package and not the mediawiki-1.46 package as distributed by Minimos. See How to fix? for Minimos:latest relevant fixed versions and status.

guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Prior to 2.12.3, Uri::assertValidHost() does not reject URI host components containing authority delimiters, embedded ports, or malformed IPv6 brackets, allowing Uri::getHost() to disagree with the URI authority used for security or routing decisions. This issue is fixed in version 2.12.3.

CVSS Base Scores

version 3.1