Improper Input Validation Affecting gnutls package, versions <10:3.6.16-4.0.1.el8_fips


medium

Snyk CVSS

    Attack Complexity Low
    Availability High

    Threat Intelligence

    EPSS 0.64% (79th percentile)
Expand this section
NVD
7.5 high
Expand this section
SUSE
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-GNUTLS-2596965
  • published 10 Apr 2022
  • disclosed 5 Aug 2021

How to fix?

Upgrade Oracle:8 gnutls to version 10:3.6.16-4.0.1.el8_fips or higher.
This issue was patched in ELSA-2022-9221.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnutls package and not the gnutls package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

A flaw was found in the way nettle's RSA decryption functions handled specially crafted ciphertext. An attacker could use this flaw to provide a manipulated ciphertext leading to application crash and denial of service.