Use After Free Affecting systemd-libs package, versions <0:239-58.0.1.el8_6.4


high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.18% (55th percentile)
Expand this section
NVD
9.8 critical
Expand this section
Red Hat
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-SYSTEMDLIBS-3008915
  • published 26 Aug 2022
  • disclosed 9 Sep 2022

How to fix?

Upgrade Oracle:8 systemd-libs to version 0:239-58.0.1.el8_6.4 or higher.
This issue was patched in ELSA-2022-6206.

NVD Description

Note: Versions mentioned in the description apply only to the upstream systemd-libs package and not the systemd-libs package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

A use-after-free vulnerability was found in systemd. This issue occurs due to the on_stream_io() function and dns_stream_complete() function in 'resolved-dns-stream.c' not incrementing the reference counting for the DnsStream object. Therefore, other functions and callbacks called can dereference the DNSStream object, causing the use-after-free when the reference is still used later.