Off-by-one Error Affecting systemd-libs package, versions <0:239-68.0.2.el8_7.1


0.0
medium

Snyk CVSS

    Attack Complexity Low
    Availability High

    Threat Intelligence

    EPSS 0.04% (11th percentile)
Expand this section
NVD
5.5 medium
Expand this section
SUSE
5.5 medium
Expand this section
Red Hat
5.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-ORACLE8-SYSTEMDLIBS-3230842
  • published 15 Jan 2023
  • disclosed 8 Nov 2022

How to fix?

Upgrade Oracle:8 systemd-libs to version 0:239-68.0.2.el8_7.1 or higher.
This issue was patched in ELSA-2023-0100.

NVD Description

Note: Versions mentioned in the description apply only to the upstream systemd-libs package and not the systemd-libs package as distributed by Oracle. See How to fix? for Oracle:8 relevant fixed versions and status.

An off-by-one Error issue was discovered in Systemd in format_timespan() function of time-util.c. An attacker could supply specific values for time and accuracy that leads to buffer overrun in format_timespan(), leading to a Denial of Service.