CVE-2022-45060 Affecting varnish-modules package, versions <0:0.15.0-6.module+el8.5.0+20320+0b4af72d



    Attack Complexity Low
    Integrity High
Expand this section
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • published 29 Nov 2022
  • disclosed 9 Nov 2022

How to fix?

Upgrade Oracle:8 varnish-modules to version 0:0.15.0-6.module+el8.5.0+20320+0b4af72d or higher.
This issue was patched in ELSA-2022-8649.

NVD Description

Note: Versions mentioned in the description apply to the upstream varnish-modules package. See How to fix? for Oracle:8 relevant versions.

An HTTP Request Forgery issue was discovered in Varnish Cache 5.x and 6.x before 6.0.11, 7.x before 7.1.2, and 7.2.x before 7.2.1. An attacker may introduce characters through HTTP/2 pseudo-headers that are invalid in the context of an HTTP/1 request line, causing the Varnish server to produce invalid HTTP/1 requests to the backend. This could, in turn, be used to exploit vulnerabilities in a server behind the Varnish server. Note: the 6.0.x LTS series (before 6.0.11) is affected.