Information Exposure Affecting centreon/centreon package, versions <21.4.16 >=21.10.0-beta.1, <21.10.8 >=22.4.0-beta.1, <22.4.1


0.0
medium
  • Attack Complexity

    Low

  • Confidentiality

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-PHP-CENTREONCENTREON-2971034

  • published

    4 Aug 2022

  • disclosed

    4 Aug 2022

  • credit

    Unknown

How to fix?

Upgrade centreon/centreon to version 21.4.16, 21.10.8, 22.4.1 or higher.

Overview

centreon/centreon is a network, system, applicative supervision and monitoring tool.

Affected versions of this package are vulnerable to Information Exposure due to a lack of proper validation within the processing of Virtual Metrics of a user-supplied string before using it to construct SQL queries. An attacker can leverage this vulnerability to disclose stored credentials.