Cross-site Request Forgery (CSRF) Affecting contao/core-bundle package, versions >=4.0.0, <5.3.50>=5.4.0-RC1, <5.7.12


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.12% (2nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-CONTAOCOREBUNDLE-21709022
  • published25 Oct 2026
  • disclosed9 Oct 2026
  • creditUnknown

Introduced: 9 Oct 2026

NewCVE-2026-107848  (opens in a new tab)
CWE-352  (opens in a new tab)

How to fix?

Upgrade contao/core-bundle to version 5.3.50, 5.7.12 or higher.

Overview

contao/core-bundle is an Open Source PHP Content Management System for people who want a professional website that is easy to maintain.

Affected versions of this package are vulnerable to Cross-site Request Forgery (CSRF) via the RequestTokenListener process. An attacker can perform unauthorized state-changing actions by tricking a logged-in backend user into loading a crafted URL. This is only exploitable if the victim is authenticated in the backend and loads the malicious URL; the actions performed are limited to the modules accessible by that user.

CVSS Base Scores

version 4.0
version 3.1