Incorrect Authorization Affecting contao/core-bundle package, versions >=5.7.0, <5.7.12


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.19% (9th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-CONTAOCOREBUNDLE-21709025
  • published25 Oct 2026
  • disclosed9 Oct 2026
  • creditUnknown

Introduced: 9 Oct 2026

NewCVE-2026-107851  (opens in a new tab)
CWE-524  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade contao/core-bundle to version 5.7.12 or higher.

Overview

contao/core-bundle is an Open Source PHP Content Management System for people who want a professional website that is easy to maintain.

Affected versions of this package are vulnerable to Incorrect Authorization due to improper caching in the TableAccessVoter process. An attacker can gain unauthorized access to sensitive database tables by making sequential requests that first access an authorized table, causing the cache to incorrectly grant access to unauthorized tables within the same session.

CVSS Base Scores

version 4.0
version 3.1