Information Exposure Affecting contao/core-bundle package, versions >=4.0.0, <5.3.50>=5.4.0-RC1, <5.7.12


Severity

Recommended
0.0
medium
0
10

CVSS assessment by Snyk's Security Team. Learn more

Threat Intelligence

EPSS
0.26% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-PHP-CONTAOCOREBUNDLE-21709027
  • published25 Oct 2026
  • disclosed9 Oct 2026
  • creditUnknown

Introduced: 9 Oct 2026

NewCVE-2026-107842  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade contao/core-bundle to version 5.3.50, 5.7.12 or higher.

Overview

contao/core-bundle is an Open Source PHP Content Management System for people who want a professional website that is easy to maintain.

Affected versions of this package are vulnerable to Information Exposure in the ModuleSearch process when the contao.search.index_protected setting is disabled. An attacker can access titles, URLs, and context snippets of protected pages by performing search queries as an unauthenticated visitor. This is only exploitable if protected pages were indexed while the setting was enabled and then the setting is subsequently disabled.

CVSS Base Scores

version 4.0
version 3.1