Cross-site Scripting (XSS) Affecting craftcms/cms package, versions <3.1.31


Severity

0.0
medium
0
10

    Threat Intelligence

    EPSS
    0.07% (30th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-CRAFTCMSCMS-450195
  • published 18 Jun 2019
  • disclosed 18 Jun 2019
  • credit Unknown

How to fix?

Upgrade craftcms/cms to version 3.1.31 or higher.

Overview

craftcms/cms is a content management system.

Affected versions of this package are vulnerable to Cross-site Scripting (XSS). Found in FeedWidget where HTML is not wrapped/escaped and is therefore vulnerable to injecting scripts.

Details

CVSS Scores

version 3.1
Expand this section

Snyk

5.4 medium
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    Required
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    Low
  • Integrity (I)
    Low
  • Availability (A)
    None
Expand this section

NVD

6.1 medium