Remote Code Execution (RCE) Affecting craftcms/cms package, versions >=3.0.0, <3.8.15 >=4.0.0-RC1, <4.4.15


Severity

0.0
high
0
10

    Threat Intelligence

    Exploit Maturity
    Proof of concept
    EPSS
    0.13% (48th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-CRAFTCMSCMS-5848033
  • published 22 Aug 2023
  • disclosed 21 Aug 2023
  • credit awakerrday

How to fix?

Upgrade craftcms/cms to version 3.8.15, 4.4.15 or higher.

Overview

craftcms/cms is a content management system.

Affected versions of this package are vulnerable to Remote Code Execution (RCE) by bypassing the validatePath function, using a file URI scheme such as file:///path1/path2.

Note: This is exploitable only for authenticated users with the configuration ALLOW_ADMIN_CHANGES=true.

CVSS Scores

version 3.1
Expand this section

Snyk

7.2 high
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    High
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    High
  • Integrity (I)
    High
  • Availability (A)
    High
Expand this section

NVD

7.2 high