Remote Code Execution (RCE) Affecting craftcms/cms package, versions >=4.0.0-RC1, <4.4.15


Severity

Recommended
0.0
critical
0
10

CVSS assessment made by Snyk's Security Team

    Threat Intelligence

    Exploit Maturity
    Mature
    EPSS
    87.29% (99th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-CRAFTCMSCMS-5901521
  • published 14 Sep 2023
  • disclosed 13 Sep 2023
  • credit Sonia Zorba

How to fix?

Upgrade craftcms/cms to version 4.4.15 or higher.

Overview

craftcms/cms is a content management system.

Affected versions of this package are vulnerable to Remote Code Execution (RCE) due to unsanitized keys in a configuration array.

CVSS Scores

version 3.1
Expand this section

Snyk

9.8 critical
  • Attack Vector (AV)
    Network
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    None
  • User Interaction (UI)
    None
  • Scope (S)
    Unchanged
  • Confidentiality (C)
    High
  • Integrity (I)
    High
  • Availability (A)
    High
Expand this section

NVD

9.8 critical