Improper Privilege Management Affecting craftcms/cms package, versions >=3.0.0, <3.9.6 >=4.0.0-RC1, <4.5.11


Severity

Recommended
0.0
medium
0
10

CVSS assessment made by Snyk's Security Team

    Threat Intelligence

    EPSS
    0.07% (32nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-PHP-CRAFTCMSCMS-6143588
  • published 4 Jan 2024
  • disclosed 3 Jan 2024
  • credit johnax0

How to fix?

Upgrade craftcms/cms to version 3.9.6, 4.5.11 or higher.

Overview

craftcms/cms is a content management system.

Affected versions of this package are vulnerable to Improper Privilege Management. An attacker can escalate privileges by manipulating user permission settings.

CVSS Scores

version 3.1
Expand this section

Snyk

5.4 medium
  • Attack Vector (AV)
    Adjacent
  • Attack Complexity (AC)
    Low
  • Privileges Required (PR)
    Low
  • User Interaction (UI)
    None
  • Scope (S)
    Changed
  • Confidentiality (C)
    None
  • Integrity (I)
    Low
  • Availability (A)
    Low
Expand this section

NVD

8.8 high